Bluehost, PHP 5.6 and You

2016.01.21 Update: Bluehost has added PDO SQLite support for PHP 5.6. Sites which previously returned in error following the 5.6 upgrade, as below, should now operate as normal.

Ourselves and a number of our customers on Bluehost have had their accounts automatically upgraded to a Beta version of PHP 5.6. Bluehost is not yet including the necessary PHP modules that our products require, so if you’ve been upgraded to PHP 5.6 you will likely find that your site is no longer functioning correctly.

We have initiated discussion with Bluehost to add support for the PDO sqlite module in PHP 5.6. In the meantime, to fix this issue, change back to the stable PHP 5.4 with the following steps.

1. Login to your site’s cpanel.

2. Click on PHP Config:

bluehost-cpanel-php54

‚Äč3. Choose one of the options for PHP 5.4, such as PHP 5.4 (FastCGI):

bluehost-cpanel-php54fastcgi

4. Click on ‘Save Changes’.

Leave a Reply

Your email address will not be published. Required fields are marked *

The Turning Gate